Classic MacでRubyが動かなくなる?

大野晋一(編集部)
2008-08-20 20:07:01
  • このエントリーをはてなブックマークに追加

 Classic MacでRubyが動かなくなるかもしれない。Rubyの開発コミュニティでは一部プラットフォームのメンテナが不足しており、このままだと、1.8では動作していたにもかかわらず、1.9が動作しないプラットフォームが出る模様だ。

 当該プラットフォームで日常的にRubyを使っていて、メンテナになれそうな人は是非メーリングリストなどで手を挙げて欲しい。コミュニティでは以下の5点をメンテナに求めている。

  • ruby-core@ruby-lang.org と ruby-dev@ruby-lang.org を購読する
  • そのプラットフォームが pthread 実装を持っていない場合は thread_{win32, pthread}.c を移植する。
  • その他のビルドエラーやプラットフォーム固有の問題を解決する
  • 日々Rubyのtrunkをビルド・テストする
  • 12月20日までに"make test-all"に成功するように努力する
次のプラットフォームではかつてRubyがメンテナンスされていましたが今はされていません。誰かがメンテナにならない限りRuby 1.9はそのプラットフォームで は動作しなくなるでしょう。

OpenVMS
WinCE
OS/2
Classic MacOS
bcc32
djgpp
human68k
builder extra - the Web filtered by humans, not bots
  • 新着記事
  • 特集
  • ブログ
このサイトでは、利用状況の把握や広告配信などのために、Cookieなどを使用してアクセスデータを取得・利用しています。 これ以降ページを遷移した場合、Cookieなどの設定や使用に同意したことになります。
Cookieなどの設定や使用の詳細、オプトアウトについては詳細をご覧ください。
[ 閉じる ]