Firebirdに複数の脆弱性

原井彰弘
2007-08-31 19:03:02
  • このエントリーをはてなブックマークに追加

 30日(現地時間)、デンマークのSecuniaはオープンソースのSQLデータベースエンジン「Firebird」に複数の脆弱性が発見されたことを発表した。

 今回発表された脆弱性は4つ。危険度は5段階の下から2番目「Less critical」。詳細は次の通り。

  • イベント登録リクエストの処理にエラーがあるため、XNETで接続されたクライアントからFirebirdサーバをクラッシュできる可能性がある。
  • ネットワークパケットの処理にエラーがあるため、大量のパケットによってCPUの負荷やメモリの消費量を増大させられる可能性がある。
  • サービスAPIの呼び出しにまだ特定されていないエラーが存在し、DoS攻撃の危険がある。
  • 「attach database」や「create database」コマンドで「MAXPATHLEN」よりも長いファイル名を渡した場合に、特定されていない脆弱性が存在する。

 これらの脆弱性は、Firebird 2.0.2以前のバージョンに存在する。Firebirdの利用者は、至急2.0.2にアップデートされたい。

  • 新着記事
  • 特集
  • ブログ
このサイトでは、利用状況の把握や広告配信などのために、Cookieなどを使用してアクセスデータを取得・利用しています。 これ以降ページを遷移した場合、Cookieなどの設定や使用に同意したことになります。
Cookieなどの設定や使用の詳細、オプトアウトについては詳細をご覧ください。
[ 閉じる ]